
AASHTOWare BrM 6.4 Release Notes

Key Features and Enhancements
l Redesigned the Multimedia module.

l Updated the Inspection > Multimedia task to use the redesigned Multimedia module.

l Added the Admin > Security > Multimedia task to manage the role-based permissions for multimedia
contexts and subfolders.

l Added the Admin > General Config > Multimedia task to configure various settings for the Multimedia
module.

l Added aMultimedia widget that can be added to any new or existing task from the Visual Form Editor.

l (BRMSD-3747) Updated the Program Optimizer to allow for multi-year, manually funded (funding allocated)
projects.

l Updated the Programs > Assign Projects task to allow for the assignment of projects to specific program
scenarios.

l Added the ability to enable/disable the optimizer log files, control the number of alternative logs maintained in
the system, and set the number of rows of data permitted in each alternative log.

l Added the ability to download optimizer log files, including the web output log and the alternative log, on the
Programs > Program Planning task.

l Added aWeighted option to the Percent Condition State field for the Element Condition State action type on
the Admin > Modeling Config > Network Policies task.

l Updated the element validation in BrM to be compliant with the latest FHWA element validation rules.

l Added the Bridges > Mapping > EnhancedMapping task that allows you to view surrounding bridges on amap
within a particular area of the selected bridge. You can also draw your own area from which to view
surrounding bridges.

Bug Fixes and Miscellaneous Updates
l (BRMSD-105) Fixed a bug that caused an error on theManage Filters task when attempting to delete a filter.

l (BRMSD-236) Fixed various calculation errors within the insp010 report.

l (BRMSD-317) Fixed a bug that displayed an inaccurate value for the "Number of Culverts" in the insp010_
bridge_condition_summary report on the Reports > Generate task.

l (BRMSD-471) Fixed a bug that caused the notes to duplicate between the Inspection and Bridge contexts on
the Inspection > Multimedia task.

l (BRMSD-580) Fixed a bug that allowed duplicate child elements on the Tunnels > Tunnel Inspection task.

l (BRMSD-694) Fixed a bug that caused errors when attempting to update and save the relative weight or health
index coefficients of certain elements on the Admin > Modeling Config > Element Spec task.

l (BRMSD-1518) Updated the inspection report selection options when generating reports on the Reports >
Generate task to ensure the latest inspection data can be pulled when selectingmultiple structures.
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l (BRMD-1648) Fixed a bugwhere hiding a task on the Admin > General Config > Standard task also hid the task
from being located and modified on the Admin > General Config > Visual Form Editor task.

l (BRMSD-1668) Fixed a bug that caused BrM to crash when attempting to delete an in-use Structure Weight
context formula from the Admin > Modeling Config > Advanced Formulas task. The fix now correctly displays a
popupmessage to inform the user that the formula is in use and cannot be deleted.

l (BRMSD-2221) Fixed a data issue in the LRReport caused by Oracle case-sensitivity.

l (BRMSD-2457) Removed duplicate wording in the note under the Follow-up Actions of the Admin > Modeling
Config > Network Policies task.

l (BRMSD-3111) Fixed a bug that caused the Minimize Cost option of the Program Optimizer to exclude or
incorrectly select projects.

l (BRMSD-3112) Fixed a bug that prevented the use of the Shift and Ctrl keys to select multiple reports on the
Admin > Security > Reports task.

l (BRMSD-3113) Updated line graphs on the Admin > Modeling Config > Executive Summary task to allow for
user tables to be used as groupings.

l (BRMSD-3114) Updated the user lists in the Admin > Security > Groups and Admin > Security > Roles tasks to
indicate inactive users with greyed out text and "(disabled)" behind the user names.

l (BRMSD-3115) Updated the Percentage Good line graph on the Admin > Modeling Config > Executive Summary
task to correctly display a percentage instead of total deck area.

l (BRMSD-3142) Corrected rules on the Admin > General Config > Validation Editor task to ensure that necessary
under records no longer show as null.

l (BRMSD-3147) Fixed a bug that prevented the database trigger TRG_BRIDGE_PRECISE_LATLON from
properly handling null latitude and longitude values in an Oracle database.

l (BRMSD-3201) Added an option to include non-FHWA elements for NBE imports and exports on the Gateway
> Import and Gateway > Export tasks.

l (BRMSD-3205) Updated the Admin > Modeling Config > Network Policies, Admin > Modeling Config > LCCA
Policy Rules, and Admin > General Config > Equation Editor tasks to allow amaximum of 10 conditions per
action/rule.

l (BRMSD-3225) Fixed a bug that prevented the use of the Enter key for quick filters on the Bridge List when
filtering a columnwith custom header text.

l (BRMSD-3268) Updated the Admin > General Config > Data Dict task to allow a null to be established in the
Sys. Default field by entering "(NULL)" or "(null)."

l (BRMSD-3322) Fixed a bug that caused errors when attempting to insert the calendar control into a page in the
Visual Form Editor.

l (BRMSD-3326) Fixed a bug that prevented the use of the Override Table Name and Override Column Name
fields to override parameters for non-bridge assets on the Admin > General Config > Visual Form Editor task.

l (BRMSD-3435) Updated the Admin > Modeling Config > Advanced Formulas task to accept Euler's number.

l (BRMSD-3452) Fixed a bug that prevented the removal of structures withmultiple structure units.

l (BRMSD-3454) Improved the error handling of advanced formulas to properly detect and issue an error for
positive infinity, negative infinity, and non-real numbers.

l (BRMSD-3470) Fixed a bug that prevented USERWAY data from carrying over to the new structure when using
the Bridges > Copy Struct feature.
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l (BRMSD-3471) Updated tunnel structure units to ensure that when deleting a structure unit on the Tunnels >
Tunnel Inventory task, all elements included with the structure unit are also deleted.

l (BRMSD-3487) Fixed a bug that prevented navigating to other inspections on the Inspection > Condition task
after navigating to a locked inspection with no element data.

l (BRMSD-3538) Fixed a bug that prevented scheduled tasks for custom reports from properly generating the
reports on the Admin > General Config > Scheduled Tasks page.

l (BRMSD-3545) Fixed a bug that prevented access filters from properly filtering out tunnels on the Tunnels >
Tunnel Inspection task.

l (BRMSD-3558) Fixed a bug that prevented some pages on the Visual Form Editor from saving if a Calendar
control was added.

l (BRMSD-3559) Fixed a bug that prevented some pages on the Visual Form Editor from saving if a Notes
control was added.

l (BRMSD-3561) Fixed a bug that caused checkbox selections for multiassets to fail to persist across pages.

l (BRMSD-3565) Fixed a bug that incorrectly used bridge count instead of deck area percentage in the program
optimizer when running a program with a surface-based performance measure.

l (BRMSD-3567) Fixed a bug that caused errors on the Analysis > LCCA task when attempting to run an analysis
after making edits to actions and policy rules.

l (BRMSD-3589) Updated the functionality of the Inspection Type filters on the Bridges > Inspection Type task to
display only the selected inspection types for all applicable bridges.

l (BRMSD-3590) Fixed a bug that prevented the addition of a work item to multiple projects.

l (BRMSD-3591) Updated the Network Policies list boxes to sort alphabetically on the Programs > Create/Edit
Programs task.

l (BRMSD-3594) Fixed a bug that prevented protective systems from applying to elements in the LCCA and
optimizer results when the protective system was not specifically assigned a parent element on the Admin >
Modeling Config > Benefits task.

l (BRMSD-3597) Fixed a bug that caused the map locations of bridges to be incorrect when newly added to
multiple groups at the same time on the Bridges > Inspection Assignment task.

l (BRMSD-3605) Fixed a display issue for Firefox and Chrome browsers on the Admin > General Config > Visual
Form Editor task.

l (BRMSD-3640) Fixed a bug that caused an error on the Bridges > Inspection Assignment task that prevented it
from loading.

l (BRMSD-3647) Updated how various browsers handle local/network files and the viewing of thumbnail
images on the Inspection > Multimedia task and the Bridge List.

l (BRMSD-3731) Fixed a bug that incorrectly truncated fields on the Inspection > Inventory pages when they
included spaces at the beginning of the entry.

l (BRMSD-3743) Removed old references to the eleminsp table on the Admin > Modeling Config > Advanced
Formulas task.

l (BRMSD-3767) Fixed a bug that caused the optimizer to stall and error when attempting to optimize a
program of more than 30,000 bridges.

l (BRMSD-3819) Fixed a bug that prevented the creation of new defects on the Admin > Modeling Config >
Element Spec task because unnecessary fields were required before saving but were hidden.
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l (BRMSD-3823) Fixed a bug that prevented budget distribution in the program optimizer when there is only one
segment and it is in perfect condition.

l (BRMSD-3839) Updated the dropdowns on the Programs > Program Comparison task to expand to fit long
program and scenario names.

l (BRMSD-3847) Fixed a bug that caused upper/lowercase inconsistencies between a filter and the database on
the Bridges > Manage Filter > Edit Filter task.

l Updated the structure unit column's tooltip on the Inspection > Work > Work Candidates task to display the
correct table.column information.

l Updated the parameters on the Programs > Scenario Explorer task to include an "ALL" option for selecting
segments.

l Fixed a bug that caused tabs hidden with the PON_NAV_TAB.VISIBLE_IND setting to revert back to visible after
running amigration script.

l Fixed a bug that incorrectly distributed more funds than available on the Programs > Funding Allocation task
when using the Distribute Evenly option.

l Improved the Excel spreadsheet download for several pages by removing the warning when opening and
updating the appearance of the displayed information.

l Updated the Program Optimizer to provide more incremental updates to the progress bar to better
communicate the status of the optimization as it runs.

l Made performance improvements to the optimizer.

l Updated the APIACCEPTSFILES option on the Admin > General Config > Options task to use a dropdown
selection rather than a blank text field.

l Fixed a bug on the Admin > General Config > Visual Form Editor task that incorrectly caused the selected tab to
clear out/change when switching between selected subtasks that do not have the same parent task.

l Fixed a bug that was preventing the Inspection > Condition task from properly validating if changes have been
made and informing the user of their options when attempting to navigate away before saving.

l Fixed a bug on the Admin > General Config > Visual Form Editor that removed the wrong tabwhen attempting to
delete a tab from the system.

l Updated the NBE import on the Gateway > Import task to accept the change in the FHWA labeling of the file
from FHWAElement to FHWAELEMENT.

l Updated the Programs > Program Planning task to disable the optimizer if a network policy and/or subdivision
profile filter segment are not assigned to the selected program on the Programs > Create/Edit Programs task.

l Fixed a bug that caused the application to crash when selecting a bridge using the "No Category" project
category on the Projects > Create/Edit Project > Query task.

l Fixed a bug that was applying benefits not called by an action on the Analysis > LCCA task.

l Limited the maximum allowable Override Budget on the Programs > Funding Allocation task to avoid errors and
ensure funds can be distributed evenly.

l Updated the Minimize Cost feature of the optimizer to better filter alternatives that meet the cost minimization
goal.

l Fixed a bug that was causing "no caption" to display for labels that were previously hidden and then unhidden
on the Admin > General Config > Visual Form Editor task.
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l Fixed a bug on the Admin > General Config > Manage Asset Types task that was causing console errors and
preventing proper validation errors from showingwhen attempting to save after clearing the Identification
Column checkbox.

l Fixed a bug that prevented saving on the Inspection > Load Rating task when using Firefox or Internet Explorer
11.

l Fixed a bug that caused errors on the Tunnels > Inventory task when attempting to change the structure units'
Default checkboxes.

l Fixed a bug that caused the system default parameter value for a given dropdown field in the Data Dict to
become out of sync with the actual default value displayed in the dropdown field in BrM.

l Added a spinning wheel to the Admin > Mapping > Sync Mapping task when syncing bridges to indicate the
action is processing.

l Fixed a bug that was preventing the Admin > General Config > Manage Asset Types task from indicating when
the page has beenmodified and not yet saved.

l Fixed a bug that was causing reports with an "as of date" to fail to generate from Admin > General Config >
Scheduled Tasks.

l Removed the asterisks that appeared by default in the Option Value field of the EMAILSMTPUSERPASSWORD
option on the Admin > General Config > Options task.

l Fixed a bug that was causing console errors on the Admin > General Config > Scheduled Tasks task when
configuring a Report Generation task using the specific structure radio button.

l Fixed various broken help links in notes modals throughout BrM.

l Fixed a bug that failed to send email messages to all team members of an assignment on the Bridges >
Inspection Assignment task when at least one team member did not have a valid email address assigned to
their user account.

l Fixed a bug that prevented the use of a layout with the pon_insp_group.name table column on the Bridges >
Inspection Assignment task.

l Fixed a bug that caused security console errors when clicking the Select All Unfiltered Markers link in the
Manage Bridges in Groupmap view of the Bridges > Inspection Assignment task.

l Added the INSPDATE field as an available Identification Column on the Admin > General Config > Manage
Asset Types task.

l Updated the UI and functionality of the Admin > Modeling Config > Cost Index task to adhere to new BrM design
standards.

l Increased the complexity of the default BrM password to improve security.

l For the Program Optimizer:

l Updated the results for the Benefit/Cost and Cost/Benefit columns to no longer scale up or down by
1000. The calculations remain accurate, but the results are now correctly displayed.

l The log now displays "Do Nothing or No Name" instead of a blank entry for the Combination Name
column.

l Fixed a bug that caused the Tunnels > Tunnel List task to crash when Data Cachingwas turned off in the
web.config file.

l Fixed a bug that prevented the ability to fix errors on the Inspection > Condition task when the inspection was in
the locked status.
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l Fixed a bug that caused BrM to crash when attempting to access the Tunnels > Tunnel List task when Data
Caching is turned off in the web.config file.

l Fixed a bug that caused data loading failures for custom fields of assets created on the Admin > General
Config > Manage Asset Types task.

l Updated the element validation checks on the Bridges > Validate task to match FHWA standards.

l Added Date Entered and Entered By fields to the Tunnels > Tunnel Inspection task.

l Updated theManage Filters > Edit SQL task to allow up to 3999 characters and to display the current characters
amount on the page.

l Fixed a bug that caused BrM to crash on the Analysis > Utility Value task when using the base value formula
from the Admin > Modeling Config > Advanced Formulas task.

l Fixed a bug that caused an error on the Admin > Modeling Config > NBI Conversion Profiles task when
attempting to run the Network NBI Rating Distribution estimate for an individual component.

l Updated the Gateway > Import task NBE XML import to no longer allow 0 Total Qty values.

l Fixed a bug that caused controls in the Admin > General Config > Visual Forms Editor task to extend too far in
size when grouped with amultiline textbox.

l Updated JQuery to version 3.5.1.

l Updated error and timeout handling on the Programs > Scenario Explorer task to include a loading icon when
data is still loading into the graphs.

l Fixed a bug that prevented the MobileBridgeCheckInOut/CheckinBridge API endpoint from working
successfully.

l Fixed a bug that caused the optimizer's costs to not match estimated project costs.

l Fixed a bug that caused newly created projects to default to an additional cost of 20%.

l Fixed a bug that failed to return an error message when attempting to save on the Inspection > Condition task
after entering invalid data in the Unrepaired Spalls field.

l Fixed a bug that prevented assigning, unassigning, or deleting projects to programs with the word or
consecutive letters "ALL" in their name due to incorrect filtering.

l Fixed a bug that incorrectly displayed values as percentages instead of dollars when visiting the Programs >
Funding Allocation task for the first time after creating a new program.

l Updated the Programs > Funding Allocation task to not allow a budget distribution greater than 100% of the
budget.

l Fixed a bug that was causing console errors on the Projects > Create/Edit Project > Management task.

l Updated the UI and functionality of the Admin > General Config > Vehicle Defs task to match updated BrM
pages.

l Fixed a bug that incorrectly calculated the percentage poor by count numbers on the Programs > Executive
Summary task.

l Fixed a bug that incorrectly displayed percentage poor by count in graphs that should be percentage poor by
area on the Programs > Executive Summary task.

l Fixed a bug that prevented the selection of custom asset types in the AssetWorkCandidate custom control.

l Updated the Optimizer to only pull the last element inspection rather than all previous element inspections.
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l Fixed a bug that prevented user role changes on the Admin > Security > Roles task from immediately taking
effect.

l Fixed a bug that failed to remove associated programs and projects on the Projects > Manage Funding >
Create/Edit Funding Sources task when deleting a funding source.

l Fixed a bug that allowed invalid special characters to be included in the header names on the Bridges > Manage
Layouts task.

l Fixed a bug that prevented the use of certain allowable special characters in the header names on the Bridges >
Manage Layouts task.

l Fixed a display issue with the BrM logo in the application.

l Fixed a but that prevented the deletion of programs with scenarios.

l Added an option to filter the Programs > Assign Projects task table by scenario.

l Updated the Admin > Modeling Config > Benefit Groups task to no longer permit benefit groups to have the
same name.

l Updated the Projects > Create/Edit Project > Management task to disable the Year Frozen checkbox when a
Target Year is not specified for the project.

l Updated the Asset Selector control on the Visual Form Editor to ensure that when creating a new asset on a
created page, the asset's non-nullable fields are required to be completed.

l Fixed a bug that caused console errors when including spaces in the numeric-only fields on the Inspection >
Inventory tasks.

l Fixed a bug on the Admin > Modeling Config > Action Defs task that did not include options with null values in the
Action Types dropdown.

l Fixed a bug that caused the AsOf function to be missing from subreports 9 and 10 of the 23Metric As of Date
report.

l Added additional columns and updated the order of the columns in the table on the Programs > Assign Projects
task.

l On the Programs > Assign Projects task, added a Layout selector for the projects grid and updated the Start
Date and Create Date fields to display in MM/DD/YYYY format.

l Fixed a bug that failed to populate the Current Date field with the inspection date when the Routine inspection
type was selected on the Tunnels > Tunnel Inspection task.

l Fixed a bug that caused an infinite loopwhen running the Oracle database create script.

l Fixed multiple import bugs and on the Gateway > Import task for importing .zip files, NBI files with an invalid
date, and .txt files.

l Fixed a bug that prevented setting read-only security on the Tunnels > Tunnel Work Candidates task.
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