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Topics Covered 

• 3D analysis of a three span curved steel rolled beam bridge 

• Diaphragm definitions 

• 3D analysis settings 

• 3D model 

 

This example describes entering a curved steel rolled beam structure in BrDR and performing a 3D FEM analysis. 

 

3D analysis of a three span curved steel rolled beam bridge 

From the Bridge Explorer, import the 3DFEM3-Curved-Steel- 3D-Example.xml file provided with this tutorial 

into BrDR. This bridge is the I-Girder design example presented in the appendix of the AASHTO Guide Specifications 

for Horizontally Curved Steel Girder Highway Bridges, 2003.  

 

The partially expanded Bridge Workspace (BWS) tree is shown below. 
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Diaphragm Definitions 

Under the Diaphragm Definitions node, double click on X Frame to open the Diaphragm Definitions window that 

shows a diaphragm definition that can be assigned to locations in the Framing Plan Detail window. No changes are 

required in this window. 

 

Note: Steel bridges may contain any of the 4 types of diaphragm definitions. Concrete bridges may only contain Type 

4 diaphragm definitions. 
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Girder System Superstructure Definition  

Double click on the Sample superstructure definition to open the Girder System Superstructure Definition window. 

Only concentric girders with a constant deck width are supported and only steel member alternatives can be created 

for a curved superstructure.  The Horizontal curvature along reference line section shows the controls to describe 

the curved geometry. 

 

The Design speed and Superelevation are used to compute the centrifugal force effects on the truck live load.  The 

high side of the roadway is assumed to be at the outside of the curve. 
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The following types of horizontal alignments are supported. 

 

 

The Distance from PC to first support line and Distance from last support line to PT are necessary to determine 

the member lengths when the first or last support line is skewed. 
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If the member starts before the defined PC location, that portion of the member is assumed to be tangent to the curve 

at the defined PC location. See Girder 4 in the following sketch. 

 

If the member ends after the defined PT location, that portion of the member is assumed to be tangent to the curve at 

the defined PT location. See Girder 4 in the following sketch. 
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Navigate to the Analysis tab of this window. This tab contains the following settings to control the 3D analysis.  

 

 

Navigate to the Specs tab of this window. The analysis of all member alternatives in the superstructure definition will 

use the following engines and specifications set on the this tab.  An exception to this is LFR rating of curved systems.  

The LFR rating is performed in accordance with the “AASHTO Guide Specifications for Horizontally Curved Steel 

Girder Highway Bridges 2003”. Note: Currently BrDR doesn’t support ASR analysis for horizontally curved 

structures. 

 

No changes are required in this window. Click Cancel to close this window without applying any changes if made 

erroneously. 
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Framing Plan Details  

Double click on the Framing Plan Details node in the BWS tree. The Layout tab of this window displays how the 

girders are located in the Structure Typical Section window. 

The highlighted fields is available for curved girder systems to locate the leftmost girder relative to the superstructure 

definition reference line. Enter a negative value if the leftmost girder is to the left of the superstructure definition 

reference line. This along with the entered girder spacing determines the computed radii of the girders. 

 

Bearings are oriented in a local coordinate system at each member support in curved girder systems.  The user can 

enter default values for the orientation of the member Support constraints on this window and then apply them to all 

members.  This is a shortcut feature to allow for ease of data entry.  The constraints can be modified on the Member 

Support window as necessary.  The constraint settings on this window are not used in the analysis, the constraint 

settings on the Member Support window are used instead.  

Select Tangent if the local x axis for bearing alignment is parallel to the tangent of the member reference line at the 

support. Select Chord if the local x axis for the bearing alignment is parallel to a specified chord angle from the 

tangent of the member reference line at the support.  The following sketch shows an example of defining a bearing 

alignment along a chord. 
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Navigate to the Diaphragms tab of this window to see how diaphragm definitions are assigned to the framing plan.  

The weight of the diaphragms will be computed by the software and applied to the 3D model. 

Diaphragms in curved girder systems can be located by one of 3 methods: 

• entering the spacing along both girders of the bay 

• entering the spacing along the left girder of the bay 

• entering the spacing along the right girder of the bay 

The Spacing reference type – Both Girders must be used when the diaphragms are not radial to either girder.  This 

spacing reference type may also be used when the diaphragms are radial as shown in this example.   

If the diaphragms are located by entering the spacing along the left or right girder of the bay, the resulting diaphragm 

location on the alternate girder will be computed by the program by casting a line perpendicular to the tangent of the 

specified girder at each spacing interval.   

 

A wizard is available to create the diaphragm locations for the user.

  

No changes are required in this window. Click Cancel to close the window without applying any changes made 

erroneously.  
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Bracing Spec Check Selection 

Double click on the Bracing Spec Check Selection node in the BWS tree. This window is used to identify which 

diaphragms should be loaded for live load for both straight and curved girder systems. 

This window contains a listing of each diaphragm location in the superstructure definition.  The first number is the 

bay number, and the second number is the numerical id of the diaphragm starting with 1 for the diaphragm at the start 

of the bay.  Selecting a diaphragm in this window will result in influence surfaces for the diaphragm members being 

generated and then loaded with the live load.  Including a lot of diaphragms in the live load analysis can greatly affect 

the run time and amount of memory needed for the analysis.  Note that the diaphragms are always included in the FE 

model.  This checkbox only controls if the diaphragm members are loaded for live load and have specification 

checking performed. 

 

No changes are required in this window. Click Cancel to close the window. 
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Structure Typical Section 

Double click on the Structure Typical Section node in the BWS tree. The width of the deck must be constant along 

the length of the structure.  The overhangs are computed based on the distance from the superstructure definition 

reference line to the leftmost girder and girder spacing entered on the Framing Plan Detail window and the deck 

width entered here. 

 

No changes are needed in this window. Click Cancel to close the window. 
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Schematic – Structure Typical Section 

With the Structure Typical Section node selected in the BWS tree click on the Schematic button from the 

WORKSPACE ribbon (or right click and select Schematic) to view the cross section of the superstructure 

definition. 
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Note in the schematic that for this example bridge, the travelway has been entered to the out to out deck width 

instead of between the parapets.  This was done to match how the structure was loaded in the appendix of the 

AASHTO Guide Spec so that results of live loading could be compared between BrDR, and the results published in 

the AASHTO Guide Spec. 
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Supports 

Double click on the Supports node under MEMBERS -> G4 to open the Supports window and see how bearings 

can be oriented for curved girder systems. For curved girder systems bearings are oriented in a local coordinate system 

at each member support.  Select Tangent if the local x axis for bearing alignment is parallel to the tangent of the 

member reference line at the support. Select Chord if the local x axis for the bearing alignment is parallel to a specified 

chord angle from the tangent of the member reference line at the support.  The following sketch shows an example of 

defining a bearing alignment along a chord. 

 

 

No changes are required in this window. Click Cancel to close the window. 
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It is not recommended that users launch an analysis during training because of the large number of degrees of 

freedom in this example. The analysis runtime will require a 64 bit PC and adequate memory that is likely not 

available on attendee laptops. 

3D Analysis Settings 

LRFD Design Review 

From the Analysis group of the DESIGN/RATE ribbon, double click on the Analysis Settings button to open the 

window as shown below. 

 

 

Select the following vehicles and settings for an HL-93 Design Review. 
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Navigate to the Output tab and select the following output controls. Check the Detailed influence line loading to 

view the centrifugal force calculations. 

 

 

With the Sample superstructure definition selected on the BWS tree, click the Analysis button from the Analysis 

group of the DESIGN/RATE ribbon. 
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Specification Check Detail - LRFD Design Review 

 

 

LFR Rating 

In the Analysis Settings window select the following vehicles and settings for an LFR rating. 
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The example in the AASHTO Guide Specification is for an HS25 loading.  To produce this loading, enter a scale 

factor of 1.25 in the Vehicle Properties window as shown below. 

 

 

Navigate to the Output tab and check the checkboxes shown below to generate detailed reports. Be sure to check the 

Detailed influence line loading to be able to view the centrifugal force calculations. 
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This example shows the results from a 3D LFD rating.  It is not recommended that users launch an analysis 

during training due to the large number of degrees of freedom in this example. The analysis runtime will 

require a 64 bit PC and adequate memory that is likely not available on attendee laptops. 

 

The software develops the 3D model using the member alternative marked as Existing for each member.  If the 

member does not have a member alternative marked as Existing and only has 1 member alternative, that member 

alternative is used for the 3D model.  If the member has no member alternative marked as Existing and more than 1 

member alternative, the analysis will not be performed. 

 

When the analysis is launched for the superstructure definition, spec checking and rating is only performed for member 

alternatives marked as Existing.  When the analysis is launched for a single member alternative (as shown below), 

the spec checking and rating will only be performed for that member alternative. 

 

 

 

A feature for both straight and curved girder system FE analysis is the ability to reuse existing FEA results.  The 

program will generate new dead load and live load influence surface FE models and compare the models to previous 

models.  If the models compare exactly then the FEA results will be reused.  The live load will be applied to the 

previous influence surfaces.  This leads to a greatly reduced runtime on successive runs.   
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Engine Outputs – LFR Rating 

From the Engine Outputs button on the Results group of the DESIGN/RATE ribbon, the following shows the output 

files created by the 3D LFR rating.  Similar files are created for a 3D LRFD design review. 

 

 

The 3D Model files list the data for the models including nodes, members, properties, and loads.  The 3D Model 

Actions files list the FE results (reactions, element actions, displacements) for the models.  The Model Graphics files 

can be opened to graphically view the FE models.  The following shows the graphics for the Stage 1 model which 

contains the steel beams and diaphragms. 
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Node and element numbers can be turned on from the Tools menu.  The mouse controls manipulation of the view.  

Zoom by rolling the mouse wheel.  Translate by pushing down the mouse wheel. Rotate by pushing down the left 

mouse button. 

The generated influence surfaces for the unit live loading can be viewed by selecting the Stage 3 Graphics model and 

then selecting File -> Open -> Influence Surfaces.sur.  This opens the Influence Surface window as shown below. 

An influence surface for viewing can be chosen by selecting Tools -> Change Influence Surface and then selecting 

desired actions. 
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Tabular Results – LFR Rating 

From the Results group of the DESIGN/RATE ribbon, click on Tabular Results to view the LFR rating results as 

shown below. 
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Specification Check Detail – LFR Rating 

From the Results group of the DESIGN/RATE ribbon, click on Specification Check Detail to view the LFR spec 

check results as shown below. 
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The centrifugal force effect calculations can be found in the detailed influence surface loading files found in the 

following folder (of the Documents folder). 

 

 

 

3D Model  

The modeling techniques used are the result of a survey of researchers and practitioners and review of several software 

packages.  

Steel Members  

The model for a girder system structure with steel girders is comprised of the following:  

• Shell elements for the deck  

• Beam elements for the top and bottom flanges.  

• Shell elements for the web. Web shell elements are divided into equal segments for web shells. The shell 

nodes may be adjusted to match diaphragm connections.  

• For curved structures, curvature is represented by straight elements with small kinks at node points instead 

of curved elements.  

• Master-slave constraints that connect the top flange to middle of deck. The distance ‘A’ as shown in figure 

below is measured from the center of the deck to the center of gravity of the top flange (including cover 

plates) at the start of G1. The same value is used everywhere for all girders to maintain horizontal elements.  
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Master-Slave

Constraints

Flange (Beam Elements)

Web (Shell Elements)

Flange (Beam Elements)

Deck (Shell Elements)

Section
Partial Elevation View of 

Model

A

 

 

The moment at a beam cross section is calculated by solving the equilibrium equations at that section. This moment 

is then used in the specification check articles in the same way that it would for a line girder analysis. 

Master-Slave

Constraints

Flange (Beam Elements)

Web (Shell Elements)

Flange (Beam Elements)

Deck (Shell Elements)

M

Element

Nodal

Forces

Section
Partial Elevation View of 

Model

A

 

 

Mesh Generation  

The FE model created by BrDR will contain nodes at the following locations.  

• Cross section property change points  

• Span tenth points  

• Support locations  
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• Diaphragm locations  

• User defined points of interest  

The user controls the mesh generation by the controls previously shown on the Superstructure Definition: Analysis 

tab. The software creates the mesh following the number of elements selected between beams or within the web of a 

steel beam and the target aspect ratio entered by the user. The presence of nodes at the locations listed above may 

result in some elements falling outside the target aspect ratio.  

The following plan views show how the mesh for this example can be controlled by the user. 

2 shells between beams, target aspect ratio = 4 

 

 

4 shells between beams, target aspect ratio = 2 
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Loading  

The program computes all the dead loads acting on the beam including the self-weight of the beam, user defined 

appurtenances on the structure typical section, wearing surfaces, diaphragms, and user defined member loads. 

Composite dead loads are applied directly to the deck shells in the 3D model in their actual location. They are not 

distributed to the girders based on the choices available in the Superstructure Loads window.  

The Stage 3 FE model is loaded with unit loads at each deck node within the travelway to generate influence surfaces 

for the beam. Lane positions and combinations are determined based on the travelway and the transverse loading 

parameters set by the user on the Superstructure Definition: Analysis Settings tab. The influence surfaces are then 

loaded with the selected vehicles to find the maximum live load effects. 
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